WordPress Gwolle Guestbook 2.5.3 Cross Site Scripting Vulnerability

2018-07-27
ID: 98706
CVE: None
Download vulnerable application: None
Advisory Title: WordPress Gwolle Guestbook Plugin XSS Security
 Vulnerability
Advisory URL:   http://www.defensecode.com/advisories.php
Software:       WordPress Gwolle Guestbook plugin
Language:       PHP
Version:        2.5.3 and below
Vendor Status:  Vendor contacted, update released
Release Date:   2018/07/24
Risk:           Medium
   1. General Overview
===================
During the security audit of Gwolle Guestbook plugin for WordPress
CMS, security vulnerability was discovered using DefenseCode
ThunderScan application source code security analysis platform.
 More information about ThunderScan is available at URL:
http://www.defensecode.com
  2. Software Overview
====================
According to the plugin developers, Gwolle Guestbook is is not just
another guestbook for WordPress. The goal is to provide an easy and
slim way to integrate a guestbook into your WordPress powered site.
 According to wordpress.org, it has more than 40,000 active installs.
 Homepage:
https://wordpress.org/plugins/gwolle-gb/
  3. Vulnerability Description
============================
During the security analysis, ThunderScan discovered Cross-Site
Scripting vulnerability in Gwolle Guestbook WordPress plugin.
 The Cross-Site Scripting vulnerability can enable the attacker to
construct the URL that contains malicious JavaScript code. If the
administrator of the site makes a request to such an URL, the
attacker's code will be executed, with unrestricted access to the
WordPress site in question. The attacker can entice the administrator
to visit the URL in various ways, including sending the URL by email,
posting it as a part of the comment on the vulnerable site or another
forum.
 To confirm the vulnerability make sure dashboard widget is added and
that there is at least one unchecked entry in the guestbook. The
vulnerability was tested using Apache web server.
 3.1 Cross-Site Scripting
  Vulnerable Function:  echo()
  Vulnerable Variable:  $_SERVER['PHP_SELF']
  Vulnerable URL:
http://vulnerablesite.com/wp-admin/index.php/"></script><script>alert(42)</script>
   File:                 gwolle-gb/admin/gb-dashboard-widget.php
  ---------
  150 <a href="<?php echo $_SERVER['PHP_SELF']; ?>"
class="button"><?php esc_html_e('Refresh', 'gwolle-gb'); ?></a>
  ---------
  4. Solution
===========
All users are strongly advised to update WordPress Gwolle Guestbook
plugin to the latest available version.
1-4-2 (www02)