OpenSSL Security Advisory [2 December 2010]
OpenSSL Ciphersuite Downgrade Attack
A flaw has been found in the OpenSSL SSL/TLS server code where an old bug
workaround allows malicous clients to modify the stored session cache
ciphersuite. In some cases the ciphersuite can be downgraded to a weaker one
on subsequent connections.
The OpenSSL security team would like to thank Martin Rex for reporting this
This vulnerability is tracked as CVE-2010-4180
OpenSSL JPAKE validation error
Sebastian Martini found an error in OpenSSL's J-PAKE implementation
which could lead to successful validation by someone with no knowledge
of the shared secret. This error is fixed in 1.0.0c. Details of the
problem can be found here:
Note that the OpenSSL Team still consider our implementation of J-PAKE
to be experimental and is not compiled by default.
This issue is tracked as CVE-2010-4252
Who is affected?
All versions of OpenSSL contain the ciphersuite downgrade vulnerability.
Any OpenSSL based SSL/TLS server is vulnerable if it uses
OpenSSL's internal caching mechanisms and the
SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG flag (many applications enable this
by using the SSL_OP_ALL option).
Users of OpenSSL 0.9.8j or later who do not enable weak ciphersuites are
still vulnerable but the bug has no security implications as the attacker can
only change from one strong ciphersuite to another.
All users of OpenSSL's experimental J-PAKE implementation are vulnerable
to the J-PAKE validation error.
Recommendations for users of OpenSSL
Users of all OpenSSL 0.9.8 releases including 0.9.8p should update
to the OpenSSL 0.9.8q release which contains a patch to correct this issue.
Alternatively do not set the SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG
and/or SSL_OP_ALL flags.
Users of OpenSSL 1.0.0 releases should update to the OpenSSL 1.0.0c release
which contains a patch to correct this issue and also contains a corrected
version of the CVE-2010-3864 vulnerability fix.
If upgrading is not immediately possible, the relevant source code patch
provided in this advisory should be applied.
Any user of OpenSSL's J-PAKE implementaion (which is not compiled in by
default) should upgrade to OpenSSL 1.0.0c.
RCS file: /v/openssl/cvs/openssl/ssl/s3_clnt.c,v
retrieving revision 18.104.22.168
diff -u -r22.214.171.124 s3_clnt.c
--- ssl/s3_clnt.c10 Oct 2010 12:33:10 -00001.129.2.16
+++ ssl/s3_clnt.c24 Nov 2010 14:32:37 -0000
@@ -866,8 +866,11 @@
s->session->cipher_id = s->session->cipher->id;
if (s->hit && (s->session->cipher_id != c->id))
+/* Workaround is now obsolete */
if (!(s->options &
RCS file: /v/openssl/cvs/openssl/ssl/s3_srvr.c,v
retrieving revision 126.96.36.199
diff -u -r188.8.131.52 s3_srvr.c
--- ssl/s3_srvr.c14 Nov 2010 13:50:29 -00001.171.2.22
+++ ssl/s3_srvr.c24 Nov 2010 14:34:28 -0000
@@ -985,6 +985,10 @@
+/* Disabled because it can be used in a ciphersuite downgrade
+ * attack: CVE-2010-4180.
if (j == 0 && (s->options & SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG) && (sk_SSL_CIPHER_num(ciphers) == 1))
/* Special case as client bug workaround: the previously used cipher may
@@ -999,6 +1003,7 @@
j = 1;
if (j == 0)
/* we need to have the cipher in the cipher
URL for this Security Advisory:
URL for updated CVS-2010-3864 Security Advisory: